# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(cm_mmc).*(-_-).*(-_-).*(-_-)"
test_str = "http://m.macys.com/shop/makeup-and-perfume/cologne-for-men?id=30088&edge=hybrid&cm_sp=us_hdr-_-beauty30088_cologne-&-grooming_COL3&cm_mmc=Carat_Social-_-facebook-_-jun2_frag_dad_gwp_fb_dr_roas_u6050067_11707_1420538-_-06062016_06162016&dclid=COjhz-annc0CFQ8FgQod-ycCPA"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.