package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\*\*([^\/]*)\*\/`)
var str = `if ( empty( $data->random ) ) {
/**
* Brief description
*
* @since 1.0
* @param int $var Variable
*/
do_function( 'identifier', $var );
/**
* Brief description
*
* @since 1.0
* @param int $var Variable
*/
dont_function( 'identifier', $var );
exit;
}
if ( empty( $data->random ) ) {
/**
* Brief description
*
* @since 1.0
* @param int $var Variable
*/
hey_function( 'identifier', $var );
exit;
}
if ( empty( $data->random ) ) {
/**
* Brief description
*
* @since 1.0
* @param int $var Variable
*/
do_function( 'identifier', $var );
exit;
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}