re = /[a-zA-Z0-9,.'!-]+/
str = '20010db8 ~~ 0a0b:12f0:0000:0 000:0000:0001~!!!!!!!!5423462554&%^%*&%^^&%&^%&#$%@!@#!#!@%!^#$*^* fdsfdsfsdfsdasddsaas dQQWQWQWQWraerrewq rewr ew rewdasdFSD FSDF SDFSD FSD FSD FSD FSD ~~~@!#@#@fsdfsdf fds fds fsd fdsfsd f fsd fsd fsd fsd fsdfds'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result