$re = '/^(?!.*%[^sd])(?!.*%d.*%d.*%d)(?!.*%s.*%s)(?=.*%s).*$/m';
$str = '%d:%d:%d:%s
%d:%d:%s
%d:%s
%f:%d:%s';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;