$re = '/[0-9]+.\w+
/';
$str = '
342543534534245
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);