const regex = /(\s*\[+?\s*(\!?)\s*([a-z]*)\s*\|?\s*([a-z0-9\.\-_]*)\s*\]+?)?\s*([^\s]+)\s*/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s*\\[+?\\s*(\\!?)\\s*([a-z]*)\\s*\\|?\\s*([a-z0-9\\.\\-_]*)\\s*\\]+?)?\\s*([^\\s]+)\\s*', 'ig')
const str = `http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[ ! css | name ] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[!css] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[ css | name ] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[css|name] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[css|] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[css] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview
[|name] http://plnkr.co/edit/Rek0aVwCGX20bFJrowWs?p=preview`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}