$re = '/(.*?\/)\d+-(.*)/';
$str = 'http://example.com/19731-la-preservacion-de-la-biodiversidad-es-crucial-para-frenar-la-desertificacion-en-zonas-aridas
http://example.com/633-afecta-la-crisis-alimentaria-ya-a-miles-de-personas
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;