$re = '`^[+]?\d+$`m';
$str = '9
5895
+95895
-89489
9.65
-9592.5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);