# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^')?(.')\1*(?:.$)?/$0\n/g;t' <<< "'a'a'a'a'b'c'c'a'a'd'e'e'e'e"