use strict;
my $str = '\'a\'a\'a\'a\'b\'c\'c\'a\'a\'d\'e\'e\'e\'e';
my $regex = qr/(?:^')?(.')\1*(?:.$)?/p;
my $subst = '$0\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";