import Foundation
let pattern = #"<tr CLASS='[^']*'>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<td CLASS='[^']*'>(.*)<\/td>[^<]*<\/tr>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
<tr CLASS='style12'>
<td CLASS='style11'>Data 1</td>
<td CLASS='red'><a href="#">test</a></td>
</tr>
<tr CLASS='style12'>
<td CLASS='style11'>Data 2</td>
<td CLASS='red'><a href="#">test</a></td>
</tr>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)