const regex = /([\/\\]).+AppData(?1)(Local|LocalLow|Roaming)(?1)((Microsoft)|(Comms)|(Application Data))(?1)(Windows|Credentials|Unistore|CryptnetFlushCache|CryptnetUrlCache|TileDataLayer)(?1)((Recent)|([[:xdigit:]]{8,})|data|WinX|Start Menu|MetaData|History)(?1)*.+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\\/\\\\]).+AppData(?1)(Local|LocalLow|Roaming)(?1)((Microsoft)|(Comms)|(Application Data))(?1)(Windows|Credentials|Unistore|CryptnetFlushCache|CryptnetUrlCache|TileDataLayer)(?1)((Recent)|([[:xdigit:]]{8,})|data|WinX|Start Menu|MetaData|History)(?1)*.+', 'g')
const str = `dad94d4a5ec169021cb27d877da 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/datareporting/archived/2016-01/1452838623875.db85652f-423e-4752-ba48-f92f7dba8d94.main.jsonlz4 (4997)
I 01/29/16 11:18PM 42 1c5f7cd088c9d7bb0688f0a7fb5c1647 0 C:/Users/kumquats/AppData/LocalLow/Microsoft/CryptnetFlushCache/MetaData/177590BD8DF47CB6507217848F55590F (deleted)
I 01/29/16 11:18PM 42 1fc49d7958354628038dd2540057b3ad 0 C:/Users/kumquats/AppData/LocalLow/Microsoft/CryptnetFlushCache/MetaData/02169143EF47694545C0E39FDF63E260 (deleted)
I 01/29/16 11:18PM 42 26c70c7243b7fed37402dbf2a8263288 0 C:/Users/kumquats/AppData/LocalLow/Microsoft/CryptnetUrlCache/MetaData/1F39B5CFACECFDE48DB25BCA2231FAC6_EFF75CC327209C24948C6870FD41C872 (404)
I 01/29/16 11:18PM 42 3f620d4113322a9aaaff843f970610c2 0 C:/Users/kumquats/AppData/LocalLow/Microsoft/CryptnetFlushCache/MetaData/309D00888F4CEE780156C56F72B25E51 (deleted)
I 01/29/16 11:18PM 42 79ccd9754d6f4e79bf7f82aae1ba8e3d 0 C:/Users/kumquats/AppData/LocalLow/Microsoft/CryptnetFlushCache/MetaData/0A66C06B927F7B7E55436479E8F06626 (deleted)
I 01/29/16 11:18PM 42 8faa1328dfd381cce0b98ec2a066712d 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/History/History.IE5/MSHist012016011420160115/container.dat (deleted)
I 01/29/16 11:18PM 42 db48b4cdbf7e452bda151751547efc1c 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Recent/AutomaticDestinations/5340079c1ec3b05a.automaticDestinations-ms (12800)
I 01/29/16 11:18PM 42 e9ee1ba5d111fb88e5c644da82f325d9 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Recent/Safe.lnk (748)
I 01/29/16 11:18PM 42 115e2a1536b9ff212ca943f2a9766cd1 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Crash Reports/InstallTime20160114060719 (10)
I 01/29/16 11:18PM 42 2d57b1d83725efe1914b375f5f09b4de 1 C:/Users/kumquats/AppData/Local/Microsoft/Windows/History/History.IE5/MSHist012016011420160115
I 01/29/16 11:18PM 42 304066807b5ab38fde9244e5f10d5371 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Recent/pwsafe.psafe3.lnk (928)
I 01/29/16 11:18PM 42 835fd67bdec01c13bd43514480a7645b 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/datareporting/archived/2016-01/1452807876204.e026d791-9363-45ec-8183-5d8622f7f17a.main.jsonlz4 (5218)
I 01/29/16 11:18PM 42 f92a6dc1f459fc693d901caf01431b01 0 C:/Users/kumquats/AppData/LocalLow/Microsoft/CryptnetFlushCache/MetaData/4C0F07F1B2376F1EC7D77412AFAA9653 (deleted)
I 01/29/16 11:18PM 42 79a05b2d540331e1c2d69d9a7f7a4e92 0 D:/Users/kumquats/AppData/Local/Application Data/Packages/Microsoft.WindowsStore_8wekyb3d8bbwe/Settings/settings.dat (32768) [1,0,32768,0,1,0,0]
I 01/29/16 11:18PM 42 844d774ca2684da211837ed7b3627fbd 0 C:/Users/kumquats/AppData/Local/Microsoft/OneDrive/logs/Personal/TraceArchive.6281.1202-82.etl (deleted)
I 01/29/16 11:18PM 42 92513eca99815fb7dde238435175d60f 0 C:/Users/kumquats/AppData/Local/Microsoft/OneDrive/setup/logs/Update_2016-01-14_151747_1f5c-1f60.log (856)
I 01/29/16 11:18PM 42 c1dad4e678e8e864feae312cb85ca455 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/saved-telemetry-pings/3d37a019-2be1-4c59-b7e1-3186ce3bc956 (10519)
I 01/29/16 11:18PM 42 c256adbb3e7b4fd9956e8c1d2c898b58 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/saved-telemetry-pings/ed4ab23e-ddac-4207-a1dc-d334c3b69f8e (10662)
I 01/29/16 11:18PM 42 ca40018609cfffae8981b76eae5dddb4 0 C:/Users/kumquats/AppData/LocalLow/Microsoft/CryptnetFlushCache/MetaData/5E9B37CE9B6D98B4D2DAB5275A2EA7C7 (deleted)
I 01/29/16 11:18PM 42 d0e75ae4b217ea07d405171a984ec914 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/datareporting/archived/2016-01/1452806297787.3d37a019-2be1-4c59-b7e1-3186ce3bc956.main.jsonlz4 (4870)
I 01/29/16 11:18PM 42 17d07c0f31a35597c311bd76098fe4ae 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/datareporting/archived/2016-01/1452785698092.ed4ab23e-ddac-4207-a1dc-d334c3b69f8e.main.jsonlz4 (5040)
I 01/29/16 11:18PM 42 2008a700e7f84e9b5d60c7492d34c637 0 C:/Users/kumquats/AppData/Local/Microsoft/OneDrive/logs/Personal/SyncEngine-2016-1-14.2117.6176.1.odl (23010)
I 01/29/16 11:18PM 42 25dda0789e8a9ecd1eff6d251d0dfc02 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/datareporting/archived/2016-01/1452807166003.19dc19ba-5089-4e49-a854-941cb5182581.main.jsonlz4 (5153)
I 01/29/16 11:19PM 42 4336f07f9b4ccdf3ec00fc44338ddf58 0 C:/Users/kumquats/AppData/Local/Microsoft/OneDrive/logs/Personal/TraceArchive.6281.1202-83.etl (deleted)
I 01/29/16 11:19PM 42 458e5d7840cf92e530d11095b19cddf0 0 C:/Users/kumquats/AppData/Local/Microsoft/OneDrive/setup/logs/Update_2016-01-14_151712_1820-1824.log (5170)
I 01/29/16 11:19PM 42 45793bc2f3799840e2de2aabfc2e0463 1 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/saved-telemetry-pings
I 01/29/16 11:19PM 42 5c2094eb68ff9c194642e84f459f5b81 0 C:/Users/kumquats/AppData/Local/Microsoft/OneDrive/logs/Personal/SyncEngine-2016-1-14.2117.8028.1.odl (24624)
I 01/29/16 11:19PM 42 79420869e7183463f9530e2f1ba903ef 0 C:/Users/kumquats/AppData/Local/Microsoft/OneDrive/setup/logs/Update_2016-01-14_152210_1750-1754.log (854)
I 01/29/16 11:19PM 42 b214a04de0f6bd6ce80e1cc1fe2172bc 0 C:/Users/kumquats/AppData/Local/Microsoft/OneDrive/setup/logs/Install-PerUser_2016-01-14_151712_17f4-e5c.log (377024)
I 01/29/16 11:20PM 42 97036c8e31110419a95bf4d30034ccd6 0 D:/Users/kumquats/AppData/Local/Application Data/TileDataLayer/Database/EDBtmp.log (2097152) [0,64,0,0,1,64,0]
I 01/29/16 11:21PM 42 d2aee2f1e0a6c925e0ed8c7c0cbe6183 0 C:/Users/kumquats/AppData/Local/Microsoft/Internet Explorer/brndlog.bak (6579) [0,2,0,0,1,1,0]
I 01/29/16 11:21PM 42 e86dd3861894a42712b0d15ba00daddd 0 C:/Users/kumquats/AppData/Local/Microsoft/OneDrive/setup/logs/Install_2016-01-14_151711_1524-9bc.log (65840)
I 01/29/16 11:22PM 42 c58f0fcca9b48f561e76ab13ed2657a5 0 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/[[IMPORT]]/79423.analytics.edgesuite.net/csma/plugin/csma.swf/Akamai_AnalyticsMetrics_clientId.sol (100)
I 01/29/16 11:22PM 42 c74573fb7e18376a756eb49d64abfbad 0 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/mutedPersistence.sol (46)
I 01/29/16 11:22PM 42 f032b1a63be8c803d2ed26e217a9d3c2 1 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/[[IMPORT]]/79423.analytics.edgesuite.net
I 01/29/16 11:22PM 42 f4274c89d65e124cf67b3520bd6055b0 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/datareporting/archived/2016-01/1452785698094.30158515-ab14-4d44-a31a-5b323902fdeb.main.jsonlz4 (5056)
I 01/29/16 11:22PM 42 f843dfa097f3c32cb0fb941790ebe74f 1 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/xslo
I 01/29/16 11:22PM 42 faf0754f5ef7c18a6ac03a6e4231ba95 1 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/xslo/cvp/core/player
I 01/29/16 11:22PM 42 fc02a2af9f5e5e8066645a6aa93fe464 1 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/[[IMPORT]]/79423.analytics.edgesuite.net/csma
I 01/29/16 11:22PM 42 098ae7e6209fb7d3faec58fe5aa64a94 1 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/[[IMPORT]]/79423.analytics.edgesuite.net/csma/plugin
I 01/29/16 11:22PM 42 1d5db8413e033ba94e2785a0f2bc294c 1 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/[[IMPORT]]
I 01/29/16 11:22PM 42 440cccde3394b19c56c5cad8dbab03ac 0 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/volumePersistence.sol (49)
I 01/29/16 11:22PM 42 45413eeffadd2cf393f74eee3adfbefc 1 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/xslo/cvp/core
I 01/29/16 11:22PM 42 7602dc461f32948d07082d8ec898108c 1 C:/Users/kumquats/AppData/Roaming/Macromedia/Flash Player/#SharedObjects/B9R3795M/z.cdn.turner.com/xslo/cvp
I 01/29/16 11:22PM 42 edc118e9b92fda850eb61e2d23edf5c5 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/weave/logs/error-sync-1452785091246.txt (18143)
I 01/29/16 11:22PM 42 f389b86369dfa44dbe77ed013fa07245 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Crash Reports/InstallTime20160113140035 (10)
I 01/29/16 11:22PM 42 04fa2d8381465a64b379d76bb7f3b8dc 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Profiles/ariznwhk.default-1442167744212/datareporting/archived/2016-01/1452785091851.93cfd792-0817-40e7-a91c-a5c22e31c160.main.jsonlz4 (5168)
I 01/29/16 11:22PM 42 215495282b4b6296a24f8626ef3dab64 0 C:/Users/kumquats/AppData/Roaming/Mozilla/Firefox/Crash Reports/InstallTime20160112030227 (10)
I 01/29/16 11:22PM 42 97f419c432e50e235e0c0d51c8e1675c 1 C:/Users/kumquats/AppData/Local/Microsoft/Windows/Shell
I 01/29/16 11:22PM 42 a09de7cf06078d45501b7a10949fb8bc 1 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Accessibility
I 01/29/16 11:22PM 42 f41be47df8da05684f730f3555dcd4aa 1 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/System Tools
I 01/29/16 11:22PM 42 50a73440a883ad94d6e3d545f20ab16c 1 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Windows PowerShell
I 01/29/16 11:22PM 42 6f1476b8cb532daec0e50a22d935eee5 1 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Maintenance
I 01/29/16 11:22PM 42 80e069021441e8dc066d5f9732cc8c2c 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/SendTo/Mail Recipient.MAPIMail (4) [0,1,0,0,0,0,0]
I 01/29/16 11:22PM 42 b156b2529304c7b61c1709ecd59204e8 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Windows PowerShell/Windows PowerShell.lnk (2236) [0,1,0,0,0,0,0]
I 01/29/16 11:22PM 42 bae6f19834d90f0c17a5d74de1c47df8 1 C:/Users/kumquats/NetHood
I 01/29/16 11:22PM 42 c27e52b0af46de0812f20ffa444fca69 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Windows PowerShell/Windows PowerShell (x86).lnk (2236) [0,1,0,0,0,0,0]
I 01/29/16 11:22PM 42 c37d4aa876fcdfa675af977999e986aa 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows Sidebar/settings.ini (80) [0,1,0,0,0,0,0]
I 01/29/16 11:22PM 42 c8be817edc3c1c63b5fdbd753a3630f8 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/SendTo/Desktop (create shortcut).DeskLink (7) [0,1,0,0,0,0,0]
I 01/29/16 11:22PM 42 c9890daa30dc73e60c9b4a7006d95e5a 1 C:/Users/kumquats/Templates
I 01/29/16 11:22PM 42 e1e4ff7192b46ab58c8cddee15d7651e 1 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Printer Shortcuts
I 01/29/16 11:22PM 42 f55cdc1b161b5b3438c2ff1251fdcf97 1 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Network Shortcuts
I 01/29/16 11:22PM 42 f9ac08819903e6bffc98e31702e2384d 1 C:/Users/kumquats/AppData/Local/Microsoft/Windows/GameExplorer
I 01/29/16 11:22PM 42 fc2ab1e3b7a3453131885f8aec3cf527 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/Shell/DefaultLayouts.xml (100216) [0,4,0,4,0,0,0]
I 01/29/16 11:22PM 42 10e140337abee4427580da648157e4db 1 C:/Users/kumquats/AppData/Local/Microsoft/Windows Sidebar/Gadgets
I 01/29/16 11:22PM 42 147f13f9bbb613d7022ddc2147ce090a 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/SendTo/Compressed (zipped) Folder.ZFSendToTarget (3) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 2a23d0b4283be05793dcd2fb055ea287 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Windows PowerShell/desktop.ini (218) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 3227fd65590af9b51c5b0bfb45f469d8 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Accessibility/Desktop.ini (568) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 3924b6280ef45974d12d2649636a8b75 1 C:/Users/kumquats/PrintHood
I 01/29/16 11:23PM 42 664d0bc17f6f60aab1c05986eed3695c 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Internet Explorer/Quick Launch/desktop.ini (148) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 79f4585dbfb91a7e2b08ceef9b637cb8 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/System Tools/Desktop.ini (992) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 7d6b694db725c5947a3496f25450a381 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Maintenance/Desktop.ini (170) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 8373c0aaad65f185e94d12ab2122bbae 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group2/2 - Search.lnk (1109) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 862153d9109b1d23da0a415c6a9c9011 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/07 - Event Viewer.lnk (1015) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 871e60e0787d1a14e571c39aedc75540 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/System Tools/Run.lnk (409) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 ba012f4b07aaef57d7e69e7d83afc408 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/03 - Computer Management.lnk (1015) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 bba012c1701ee0c85c007a0819b8f13d 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/10 - Programs and Features.lnk (1087) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 bd167e614ae673886a8a5e83e323885f 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/09 - Mobility Center.lnk (1015) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 caf6778bd966af8afa9d637752df070f 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/System Tools/Devices.lnk (813) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 d5d7b355abbba1e409fe2370e9e8776e 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/01 - Command Prompt.lnk (1015) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 dd9b3f8203fe124de1066ef240cf097d 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/08 - Power Options.lnk (1073) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 ffabbde394d1121fa83fa1196a2a98ab 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group2/3 - Windows Explorer.lnk (1109) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 0ca6b33070bc14ba5b6b765360157d62 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/System Tools/Control Panel.lnk (405) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 0ee3cbf9d670b146d70d687e0945ce65 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/System Tools/Command Prompt.lnk (1142) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 0fdf92f3ec3c7dd60408a969e59e20ab 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Accessories/Notepad.lnk (1158) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 112d69b13ebaba030953481f001b72dc 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Internet Explorer/Quick Launch/Shows Desktop.lnk (352) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 199233bee2d71ed1a37dd416249d1772 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/System Tools/computer.lnk (335) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 1ce74998e3e6fcc222485c58eda27908 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group2/4 - Control Panel.lnk (1015) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 1e4a222e445dd17c5b278af0faeaff5f 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Internet Explorer/Quick Launch/Window Switcher.lnk (334) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 243e54df5187dbed1e5f2458a57c6d5e 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/System Tools/File Explorer.lnk (407) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 247869d39224c40e0eaa442e81dd9c30 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group2/1 - Run.lnk (1109) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 2ce19e46b6f4886e92ab20b8247a0d91 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Windows PowerShell/Windows PowerShell ISE.lnk (1274) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 2d041cc6b06522e5ef4315d9893663f2 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/05 - Device Manager.lnk (1075) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 2fce6178e379f23907021a713384a369 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/01a - Windows PowerShell.lnk (1127) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 375fac3332c99770743b7eb4679c8097 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group1/1 - Desktop.lnk (1109) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 3fbff550c3675ab1b6d86ced4ea7e5bc 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/02a - Windows PowerShell.lnk (1171) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 417a4eeaec4cf6317d83e53a089ea718 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/02 - Command Prompt.lnk (1059) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 4f9e717ec007e43fe9e06b758140faa5 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Accessibility/Magnify.lnk (1106) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 51387196928b90c70db4ce2c5a24f4c7 0 C:/Users/kumquats/AppData/Local/Microsoft/Windows/WinX/Group3/04-1 - Network Connections.lnk (1097) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 522136d0ffe8414b9c4fda20cdcef4f0 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/System Tools/Default Apps.lnk (815) [0,1,0,0,0,0,0]
I 01/29/16 11:23PM 42 53437cd31a7ed8c4978c53d261810789 0 C:/Users/kumquats/AppData/Roaming/Microsoft/Windows/Start Menu/Programs/Accessibility/On-Screen Keyboard.lnk (1106) [0,1,0,0,0,0,0]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}