import Foundation
let pattern = #"imageBigViewURL=\[(.+?)\];"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<script type="text/javascript">
if(!window.runParams) {
window.runParams = {};
}
window.runParams.imageServer="http://i00.i.aliimg.com";
window.runParams.imageDetailPageURL="//www.aliexpress.com/item-img/2015-Winter-Beanies-Solid-Color-Hat-Unisex-Plain-Warm-Soft-Beanie-Skull-Knit-Cap-Hats-Knitted/32462312884.html";
window.runParams.imageBigViewURL=[
"http://g02.a.alicdn.com/kf/HTB1JJG8JpXXXXb7XFXXq6xXFXXXs/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg",
"http://g02.a.alicdn.com/kf/HTB1frm7JpXXXXbFXFXXq6xXFXXXo/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg",
"http://g02.a.alicdn.com/kf/HTB1BsaSJpXXXXa3aXXXq6xXFXXX9/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg",
"http://g02.a.alicdn.com/kf/HTB1tUYfJpXXXXbVXXXXq6xXFXXXc/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg",
"http://g04.a.alicdn.com/kf/HTB1LRSUJpXXXXaeaXXXq6xXFXXXr/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg",
"http://g02.a.alicdn.com/kf/HTB1VSi8JpXXXXbUXFXXq6xXFXXXU/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg"
];
window.runParams.mainBigPic = "http://g02.a.alicdn.com/kf/HTB1JJG8JpXXXXb7XFXXq6xXFXXXs/2015-зимние-шапочки-сплошной-цвет-шляпа-мужская-обычная-теплый-мягкий-шапочка-череп-вязаные-Touca-Gorro-шапки.jpg";
</script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)