const regex = new RegExp('N([1-9][0-9]{0,3}[A-HJ-NP-Z]{2}|[1-9][0-9]{0,3}[A-HJ-NP-Z]|[1-9][0-9]{0,4})', 'mg')
const str = `Should Match
N12345
N1234Z
N123AZ
N1
N99
Should not match
N01Z
N12PI
N56OT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}