re = /N([1-9][0-9]{0,3}[A-HJ-NP-Z]{2}|[1-9][0-9]{0,3}[A-HJ-NP-Z]|[1-9][0-9]{0,4})/m
str = 'Should Match
N12345
N1234Z
N123AZ
N1
N99
Should not match
N01Z
N12PI
N56OT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end