// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)N([1-9][0-9]{0,3}[A-HJ-NP-Z]{2}|[1-9][0-9]{0,3}[A-HJ-NP-Z]|[1-9][0-9]{0,4})").unwrap();
let string = "Should Match
N12345
N1234Z
N123AZ
N1
N99
Should not match
N01Z
N12PI
N56OT";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}