$re = '`https://www\.google\.co\.uk/(?!.*=(?:isch|shop)$).*$`m';
$str = 'https://www.google.co.uk/search?q=SSD&tbm=isch
https://www.google.co.uk/search?q=SSD&tbm=shop
https://www.google.co.uk/search?q=SSD&tbm=other';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);