#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)الدولار(.\d+)"
Local $sString = "some other text" & @CRLF & _
"يمة بيع الدولار 550" & @CRLF & _
"قيمة بيع اليورو 600" & @CRLF & _
"قيمة شراء الدولار 700" & @CRLF & _
"قيمة122" & @CRLF & _
"ا هي قيم العملة يوم 4/2/2022 الساعة 9:00:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")