$re = '/^(\d{3})(\d)/m';
$str = '0781
00840
8660
7100
25011';
$subst = "\1.\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;