import Foundation
let pattern = #"(gclid|utm_[a-z]+)=[-_A-z0-9+()%.]+&?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""http://wearychef.com/chicken-spaghetti-casserole/?utm_source=MadMimi&utm_medium=email&utm_content=7+Easy+Dinner+Recipes+Featuring+Chicken+Spaghetti+Casserole+(PLUS+A+Call+For+Feedback)&utm_campaign=20150620_m126272097_06202015+chicken+spaghetti+and+menu+126&utm_term=Chicken+Spaghetti+Casserole""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)