$re = '/^(?<date>[^\s]+) (?<time>[^\s]+) - (?<message>.*)$/';
$str = '2016-08-17 20:07:22 - Hello there';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);