import re
regex = re.compile(r"^[^:]*:\s*([^.]+).*", flags=re.MULTILINE)
test_str = "Prayer: Lord. Have mercy on."
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)