$re = '/^[^:]*:\s*[^.]+\.\s*([^.]+).*/m';
$str = 'Prayer: Lord. Have mercy on.';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;