using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S)\1{3,}|(\S)\2{2}";
string input = @"aaaa**!!!cccc333**
aaabbbbaaa
aaabbbbbbaaa****ccc
!!! aaaabbbaaa ccc!!!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}