const regex = new RegExp('(\\S)\\1{3,}|(\\S)\\2{2}', 'gm')
const str = `aaaa**!!!cccc333**
aaabbbbaaa
aaabbbbbbaaa****ccc
!!! aaaabbbaaa ccc!!!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}