#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = " ?(\d+.\d+|\d+)(-)(\d+.\d+|\d+)"
Local $sString = "FAST.65" & @CRLF & _
"FAST.65-160" & @CRLF & _
"<114" & @CRLF & _
">289" & @CRLF & _
"<=152" & @CRLF & _
">=107" & @CRLF & _
"10.9" & @CRLF & _
"111.11" & @CRLF & _
"12.20" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"LESS THAN 0.1" & @CRLF & _
"LESS THAN 5" & @CRLF & _
"LESS THAN 9999" & @CRLF & _
"" & @CRLF & _
"< 0.1" & @CRLF & _
"< 999" & @CRLF & _
" < 99999.99" & @CRLF & _
" " & @CRLF & _
"<5" & @CRLF & _
"< 5" & @CRLF & _
"<5.55" & @CRLF & _
"" & @CRLF & _
"<= 6" & @CRLF & _
"LE 6" & @CRLF & _
"<=666.666" & @CRLF & _
"" & @CRLF & _
"LT 6" & @CRLF & _
"LT 6.666" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")