import re
regex = re.compile(r" ?(\d+.\d+|\d+)(-)(\d+.\d+|\d+)")
test_str = ("FAST.65\n"
"FAST.65-160\n"
"<114\n"
">289\n"
"<=152\n"
">=107\n"
"10.9\n"
"111.11\n"
"12.20\n\n\n"
"LESS THAN 0.1\n"
"LESS THAN 5\n"
"LESS THAN 9999\n\n"
"< 0.1\n"
"< 999\n"
" < 99999.99\n"
" \n"
"<5\n"
"< 5\n"
"<5.55\n\n"
"<= 6\n"
"LE 6\n"
"<=666.666\n\n"
"LT 6\n"
"LT 6.666\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")