package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:\.?\d+){0,2}$`)
var str = `10.2.15
10.11
11
111.234.43556
10..2.15
10.2..15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}