using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(0[0-7]+))|(?=(0(x|X)[A-F\da-f]+))|(?=((\-|\+|)[1-9]\d*))(?=(\d+\.\d+))$";
string input = @"0x234fA
0X234fA
07245
00
56789
20
+20
-20
0.0
20.10
+20.10
-20.10
-20.34.56
20.10e10
-20.10e10
20.10e-10
-20.10e-10
20.10E10
-20.10E10
20.10E-10
-20.10E-10
+20.10e10
+20.10e-10
+20.10E10
+20.10E-10
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}