# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([{,])(\w+)(\s+)?:/$1"$2":/gmi;t' <<< "[{endTime:\"2019-06-05T17:15:00.000+10:00\",startTime:\"2019-06-05T17:00:00.000+10:00\"}]"