import Foundation
let pattern = #"([{,])(\w+)(\s+)?:"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"[{endTime:"2019-06-05T17:15:00.000+10:00",startTime:"2019-06-05T17:00:00.000+10:00"}]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"$2":"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)