#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+)\s?=\s?(['\"]?)(\S*)\2$"
Local $sString = "param1=abc" & @CRLF & _
"param2 = abc" & @CRLF & _
"param3 = "ab'c"" & @CRLF & _
"param4='a"b"c'" & @CRLF & _
"param5="abc=def""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")