import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+)\\s?=\\s?(['\\\"]?)(\\S*)\\2$";
final String string = "param1=abc\n"
+ "param2 = abc\n"
+ "param3 = \"ab'c\"\n"
+ "param4='a\"b\"c'\n"
+ "param5=\"abc=def\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}