const regex = new RegExp('^(\\w+)\\s?=\\s?([\\'\\"]?)(\\S*)\\2$', 'gm')
const str = `param1=abc
param2 = abc
param3 = "ab'c"
param4='a"b"c'
param5="abc=def"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}