$re = '/(?<=[a-z])(?=[A-Z])/m';
$str = 'Name Surname
Name Surname
Name Surname
NameSurname
NameSurname
Name Surname
Name Surname';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;