#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*"
Local $sString = "Name Surname" & @CRLF & _
"Name Surname" & @CRLF & _
"Name Surname" & @CRLF & _
"Name Surname" & @CRLF & _
" Name Surname" & @CRLF & _
"Name Surname" & @CRLF & _
"Name Surname"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)