re = /^\s*/m
str = 'Name Surname
Name Surname
Name Surname
Name Surname
Name Surname
Name Surname
Name Surname'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result