# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-+\d+$//gm;t' <<< "-500--550
-600--650
-700--750
-8000--8500
-9000--9500
-100-200
200-400"