// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-+\d+$").unwrap();
let string = "-500--550
-600--650
-700--750
-8000--8500
-9000--9500
-100-200
200-400";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}