use strict;
my $str = 'this.is.Valid
also_a_valid_1
Me-too.im_an-ugly.but_vALid-5tring
this..should..not.be.valid....
THIS__.-also-should..fail-
why..IS_regex--so.confusing-for-n0obs';
my $regex = qr/^[a-z0-9]+(?:[._-][a-z0-9]+)*$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}