# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d+:\d+\s+(?:.*?\",\")(?<user>[^\"]+)(?:.*?\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?<src>[^\"]+)(?:\",\")(?<dst>[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?<action>[^\"]+)(?:.*?\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?<svc>[^\"]+)(?:.*?\",\")(?<application>[^\"]+)(?:.*?\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?:[^\"]+)(?:\",\")(?<ruleName>[^\"]+)(?:.*?\",\")"
test_str = "Fri Feb 24 23:45:52 2023\",\"San Francisco->San Francisco->SFO-Servers\",\"Default Department\",\"San Francisco->San Francisco->SFO-Servers\",\"53\",\"53544\",\"53\",\"39474\",\"172.17.129.110\",\"156.154.71.5\",\"104.129.192.104\",\"128.177.129.156\",\"157.130.202.234\",\"0\",\"GRE\",\"Allow\",\"Yes\",\"Yes\",\"No\",\"DNS\",\"dns\",\"UDP\",\"Miscellaneous or Unknown\",\"United States\",\"1\",\"Default Allow\",\"143\",\"86\",\"0\",\"1\",\"1\",\"None\",\"None\",\"None\",\"NA\",\"NA\""
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.