$re = '/^\s*rpc (\w+).*/m';
$str = ' rpc Ammend
rpc Cancel
rpc Copy
rpc Suspend';
$subst = "rpc $1(Service$1Request) returns (Service$1Response) {}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;