import Foundation
let pattern = #"^\s*rpc (\w+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
rpc Ammend
rpc Cancel
rpc Copy
rpc Suspend
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"rpc $1(Service$1Request) returns (Service$1Response) {}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)