Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^((struct *[a-z0-9_]+)|[a-z0-9_]+) *[*a-z0-9_]+\((void|((((struct *[a-z0-9_]+)|[a-z0-9_]+) *[*a-z0-9_]+)(, ((struct *[a-z0-9_]+)|[a-z0-9_]+) *[*a-z0-9_]+)*))\)
/
gm
Test String
New
int a_0(void) int b_1(int a) int c_2(int a, int b) void *xmalloc(size_t n) int main(int argc, char **argv) void *xmalloc(size_t n) void release(struct s_block) int a_(int a, int b) int main(void) struct student get_student(char *name) struct student *grow_2fast(struct student *s, int age_diff) struct student *grow_2fast(struct student *s, struct hello age_diff) int main(void) int print_me(int h1) /* **int main(void) */