$re = '/(?!\bbar\b)\b[A-Za-z-]*bar[a-z-]*\b/';
$str = 'Belly up to the bar boys but watch
out for that barrel.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);