using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*([.,']).*\1)[a-zA-Z.,']*$";
string input = @"String.,'
y.yy
.bb,b
y,yyy.
.b'bb
bbb'
a,y.
a,z,f
y.t.e
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}