use strict;
my $str = '1 000.00
1000,00
343 444.45
Subtotal, 1 000.00 EUR
VAT 1000,00
Total, sum: -343 444.45 EUR';
my $regex = qr/-?[0-9]{1,3}(?: ?[0-9]{3})*[.,][0-9]{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}