$re = '/-?[0-9]{1,3}(?: ?[0-9]{3})*[.,][0-9]{2}/m';
$str = '1 000.00
1000,00
343 444.45
Subtotal, 1 000.00 EUR
VAT 1000,00
Total, sum: -343 444.45 EUR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);