// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{4}").unwrap();
let string = "0127,Central WM
0128,Central WM
0129,Central WM
0130,Central WM
089I,Inbound EWM
089O,Outbound EWM
089P,PSA in EWM
9988,Packstücke WM
CM01,CM01 in 1000
CM02,CM02 in 1000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}