#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!;)(?!"(;|$))""
Local $sString = "1;200;345;"Apotheker "Blue tongue"";"Apeldoorn";12;"ABCD12"" & @CRLF & _
"2;232;312;"Café "Blue Oyster";"Rotterdam";33;"DCBA21""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")